Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 icon

Реферат на тему " Експортні системи" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000



НазваРеферат на тему " Експортні системи" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000
Дата конвертації16.01.2013
Розмір129.61 Kb.
ТипРеферат
скачать >>>






Реферат

на тему

Експортні системи”

План

1. Використання технології OLE, експорту/імпорту файлів

2. Експорт/імпорт даних у додатках Microsoft Office 2000

2.1 Використання буфера обміну

2.2 Імпорт текстового файлу з роздільниками

2.3 Зв'язок Excel з Access

2.4 Імпорт і зв'язування даних у Access

2.5 Експорт даних з Access у Word і Excel

2.6 Експорт документів у HTML-формат


3. Експорт даних MACROMEDIA FLASH

Висновки

Список використаних джерел

Експортні системи – це такі системи які відповідають за експорт і імпорт даних - процес вивантаження даних з перетворенням в один із зовнішніх форматів.

При експорті в додатки Windows використовується технологія OLE.


^ 1. Використання технології OLE, експорту/імпорту файлів

OLE (Object Linking and Embedding) — технологія зв'язування і впровадження об'єктів, що дозволяє програмам спільно використовувати дані. Приклад використання технології OLE — додавання таблиць Excel у документ Word.

Технологія OLE є одним з найбільш могутніх засобів Windows, що забезпечують спільну роботу різних додатків і обмін інформацією між ними.

Використовуючи OLE, користувач може вставляти в документ, створений в одному додатку Windows, об'єкти інших додатків. Наприклад, можна вставити креслення чи фрагмент, розроблений за допомогою КОМПАС, у текстовий документ Microsoft Word. Надалі вставлений об'єкт (документ) можна відредагувати, причому для редагування будуть використовуватися команди "рідного" для даного об'єкта додатка (тобто для редагування вставленого в Word креслення чи фрагмента буде активізуватися КОМПАС).

Вставляти в інші документи можна тільки файли креслень і фрагментів цілком. Вставка окремих об'єктів КОМПАС через буфер обміну (Clipboard) у даний час не підтримується (КОМПАС використовує свій власний буфер обміну, що відрізняється від стандартного Clipboard).

Можна виконати вставку таким чином, щоб був збережений зв'язок з файлом-джерелом і виконувалося автоматичне відновлення вставки при внесенні змін у файл-джерело.

Інтерфейси з іншими системами CAD/CAM Будь-яка сучасний програмний продукт повинний вміти обмінюватися даними з іншими популярними продуктами свого класу.

КОМПАС підтримує два найбільш популярні стандарти передачі інформації між системами CAD/CAM - DXF і IGES. Це дозволяє йому обмінюватися даними практично з усіма відомими продуктами, тому що усі вони також можуть читати і записувати інформацію в цих форматах.

Експорт/імпорт файлів у форматі DXF

Для обміну даними з популярною системою AutoCAD компанії Autodesk Inc. (США), а також з іншими програмними продуктами САПР передбачена підтримка символьного формату DXF.

Для читання файлу, записаного у форматі DXF, виконують наступне.

  1. Виберіть у меню Файл команду Імпорт - Читати DXF.

  2. У стандартному діалозі відкриття файлів виберіть ім'я файлу для читання.

  3. У діалозі параметрів читання установіть потрібні опції.

Ви можете вибирати одиниці виміру в результатом файлі (дюйми чи міліметри). Якщо надалі Ви будете допрацьовувати імпортоване зображення засобами КОМПАС, рекомендується включити опцію Ігнорувати штрихування.

Експорт/ імпорт файлів у форматі IGES

Для обміну даними з численними CAD/CAM системами, що працюють на IBM-сумісних і інших платформах, передбачена підтримка формату IGES

Для читання файлу, записаного у форматі IGES, виконаєте наступне.

1. Виберіть у меню Файл команду Імпорт - Читати IGES.

2. У стандартному діалозі відкриття файлів виберіть ім'я файлу для читання.

3. У діалозі параметрів читання установите потрібні опції.

Натисніть кнопку Почати читання для імпорту IGES-файлу.


^ 2. Експорт/імпорт даних у додатках Microsoft Office 2000

Користувачам офісних додатків часто приходиться обробляти інформацію з різних джерел, а виходить, постійно зіштовхуватися з необхідністю імпорту й експорту даних. При цьому необхідно піклуватися, щоб перенесення даних з одного формату в іншій виконувався без помилок і утрат важливої інформації.

У цьому пункті роботи розглядається взаємний обмін даними між основними додатками Microsoft Office: Word, Excel і Access, а також операції експорту/імпорту у формат HTML.

При роботі з даними інформацію зручніше за все зберігати й обробляти в табличному виді. Працювати з таблицями дозволяють практично всі основні додатки Microsoft Office 2000:

  • у текстовому редакторі Word щонайкраще можна оформити таблиці для печаті;

  • в електронних таблицях Excel зручно проводити аналіз даних і результатів розрахунків як у табличній формі, так і за допомогою діаграм;

  • нарешті, у базах даних Access можна максимально ефективно обробляти великі обсяги табличних даних.

Кожен офісний додаток має свої «фірмові» можливості, тому для ефективної роботи з документами й інформацією в одній програмі краще передоручити виконання окремих задач іншому додатку. Наприклад, табличні розрахунки легко і зручно зробити в Excel, однак створити красиво отформатовану таблицю для печаті краще в Word. А виходить, нам буде потрібно імпортувати дані з Excel у Word.


^ 2.1 Використання буфера обміну

Найпростіший спосіб перенесення даних з однієї офісної програми в іншу — скористатися буфером обміну.

Щоб помістити інформацію в буфер обміну, потрібно виділити дані і вибрати в меню команду Правка →Копіювати (чи Правка → Вирізувати). Усі додатки Microsoft Office 2000 працюють із загальним буфером обміну, у який можна помістити до 12 різних фрагментів. Для перегляду вмісту буфера обміну потрібно викликати спеціальну панель «Буфер обміну» (меню Вид → Панелі інструментів → Буфер обміну).

Для вставки довільного фрагмента з буфера обміну потрібно установити курсор у позицію вставки, а потім у панелі «Буфер обміну» вибрати фрагмент, що вставляється. Якщо ж потрібно вставити останній скопійований (чи вирізаний) фрагмент, то можна використовувати звичну команду меню Правка → Вставити чи кнопку Вставити панелі інструментів «Стандартна».

При уставці фрагмента з буфера обміну дані звичайно містяться у форматі, що дозволяє їх редагувати. Так, осередку робочих аркушів Microsoft Excel і запису баз даних Microsoft Access вставляються в Word як таблиці Word, зі збереженням ширини стовпців і параметрів форматування шрифту. Текст Microsoft Word, що містить символи табуляції, буде вставлений в осередки листа Microsoft Excel з розподілом по рядкам і стовпцям (мал. 1). Записи з Microsoft Access уставляються на лист Microsoft Excel у виді рядків, з відображенням кожного поля в окремому стовпці.

О
днак якщо програма не дозволяє редагувати дані, то їх потрібно вставити у вигляді впровадженого об'єкта, який можна редагувати у вихідній програмі, відкривши об'єкт подвійним щигликом миші. Наприклад, у такий спосіб поводиться діаграма, створена в Excel, якщо вставити її в документ Word. Нарешті, якщо дані не можуть бути вставлені у вигляді впровадженого об'єкта (наприклад, при копіюванні даних із програми, що не підтримує механізм ОLЕ), то вони повинні бути поміщені у вигляді незмінного малюнка.

Рис. 1. Буфер обміну (таблиця з Excel у Word)

Для самостійного керування форматом даних, що вставляються з буфера обміну, треба замість команди меню Правка → Уставити використовувати команду Правка → Спеціальна вставка…У цьому випадку у вікні, що відкрилася, «Спеціальна вставка» (мал. 2) можна вибрати зі списку варіант кінцевого результату вставки.

Р
ис. 2. Спеціальна вставка з Excel у Word

Наприклад, за допомогою Спеціальної вставки таблицю, скопійовану з Excel, можна вставити в Word не тільки у вигляді отформатованої таблиці Word, але і як упроваджений лист Microsoft Excel, неформатований текст, а також у вигляді крапкового чи векторного малюнка.


^ 2.2 Імпорт текстового файлу з роздільниками

Якщо у вас усе ще збереглися дані, створені в «старих» текстових редакторах під MS-DOS, то давно настав час перенести їх у Word, Excel чи Access.

Файли DоS'овських текстових редакторів зберігають тільки текстову інформацію, а в таблицях таких документів звичайно для поділу використовуються символи пробілів, табуляції, символів «!», «:», «;» і ін.

Щоб зробити перенесення даних, у Excel вибираємо команду Файл а Відкрити…,тип файлу «Текстові файли» і натискаємо кнопку «Відкрити». Запускається майстер імпорту текстів (мал. 3).

На першому кроці майстра потрібно вказати, формат, у якому зберігаються вихідні дані, тобто чи використовуються роздільники у вихідному документі, а також кодування, у якій зберігається текст. Потім потрібно вказати символ-роздільник і додаткову інформацію про тип і формат вихідних даних. У результаті текст буде перекодований і вставлений у вигляді таблиці в Excel.


Р
ис. 3. Імпорт у Excel текстового файлу з роздільниками

Приблизно так само працює майстер імпорту текстових файлів з роздільниками в MS Access, тільки при його роботі додатково можна вказувати мову і кодування вихідного тексту.

До речі, для більш коректного імпорту текстового файлу бажано заздалегідь дещо підкоректувати його вміст, щоб кількість і місце розташування роздільників у кожнім рядку збігалося.


^ 2.3 Зв'язок Excel c Access

У додатках MS Office для обміну даними передбачені три типи дій: експорт, імпорт і зв'язування. При операціях експорту й імпорту отриманий результат не зв'язаний з вихідними даними, а є їх копією. У свою чергу, при операції зв'язування дані продовжують зберігатися у вихідному документі, а звертатися до них можна з інших зв'язаних документів. Таким чином, зв'язування дозволяє при роботі з одним джерелом даних використовувати можливості різних додатків.

Припустимо, ви працюєте з даними в Excel і хочете скористатися можливостями MS Access. Для цього вам буде потрібно встановити зв'язок з Access. У Excel у меню Сервіс → Надбудови потрібно включити надбудову AccessLinks (мал. 4) (можливо, для її установки потрібно дистрибутив MS Office 2000). Надбудова AccessLinks дозволяє використовувати форми і звіти MS Access при роботі з даними MS Excel. У меню Дані в Excel будуть додані три команди:

  • Форма MS Access...;

  • Звіт MS Access…;

  • Перенести в MS Access…...

Р
ис. 4. Включення надбудови AccessLinks у Excel

При виборі команди Дані → Форма MS Access відбудеться наступне:

  • на вибір буде створена нова чи відкрита існуюча база даних;

  • у цій базі даних автоматично буде встановлений зв'язок з вихідною таблицею Excel і запущений майстер форм Access, що пропонує створити нову форму;

  • виконавши всі кроки майстра форм, ви одержите екранну форму Access для роботи з даними Excel.

Аналогічно працює команда Дані → Звіт MS Access, тільки в результаті буде створений стандартний звіт Access.

Команда Дані → Перенести в MS Access... запустить Access і виконає експорт даних з Excel у таблицю нової чи існуючої бази даних Access.

На робочому листі Excel з'являються кнопки для відкриття форми (чи звіту) у Access, а після перенесення даних з'являється напис про успішне його закінчення (мал. 5). За допомогою цих кнопок можна повторно викликати створені в Access форми чи звіти, зв'язані з даними, що зберігалися на робочому листі.

Можна досягти подібного результату, працюючи в MS Access з даними з електронних таблиць Excel.






Рис. 5. Таблиця Excel, зв'язана з формою і звітом Access


^ 2.4 Імпорт і зв'язування даних у Access

Серед всіх офісних додатків фірми Microsoft система керування базами даних Access 2000 спеціально призначена для роботи з табличними даними.

У Access маються можливості:

  • зберігати великі обсяги даних у взаємозалежних таблицях;

  • створювати складні запити для добору записів (табличних рядків) і виконання обчислень за даними з декількох таблиць;

  • автоматично змінювати безліч записів за допомогою запитів дії;

  • і нарешті, створювати власні форми і звіти для зручного введення, редагування й аналізу даних.

Щоб використовувати всі ці переваги, необхідно буде перенести в Access дані з інших офісних додатків.

Передати інформацію в Access можна за допомогою імпорту чи шляхом установки зв'язку з джерелом даних.

Операція Імпорт має на увазі одержання ззовні і збереження копії даних «прийнятного» формату. При цьому зв'язок із джерелом вихідних даних підтримуватися не будуть (тобто дані стають «рідними» для Access і «забувають» про своє попереднє місцезнаходження).

Спробуємо перенести дані з робочої книги Excel у Access. Для цього в меню Файл виберемо команду Зовнішні дані → Імпорт.

У діалоговому вікні, що відкрилося, «Імпорт» виберемо тип файлів «Microsoft Excel», укажемо вихідний файл Excel і натиснемо кнопку Імпорт. Після цього почне роботу майстер, що дозволяє імпортувати в Access вміст обраного робочого чи листа іменованого діапазону осередків.

Імпорт іменованого діапазону може знадобитися у випадку, якщо на одному робочому листі розміщено кілька таблиць чи поряд з табличними даними є й інші об'єкти (написи, малюнки чи діаграми). Кожному з таких діапазонів можна привласнити ім'я. Для цього необхідно виділити діапазон осередків, у якому розміщені дані табличного виду, а потім у віконці «Ім'я» (на самому початку рядка формул) увести назва діапазону і натиснути Enter.

З книги Excel можна імпортувати в таблицю Access відібрані стовпці з зазначеного діапазону чи робочого листа. Тип даних, що зберігаються в полях (стовпцях) значень, розпізнається по вмісту декількох перших записів (рядків), тому після імпорту часто потрібно його коректування.

Іноді буває зручно працювати з одними й тими самими даними одночасно то з Excel, то з Access (тобто редагувати і додавати дані в таблицю як при роботі в Excel, так і при обробці інформації в базі даних MS Access). У цьому випадку потрібно в базі даних Access створити Зв'язки з таблицями Excel.

Для установки зв'язку бази даних із зовнішньою таблицею необхідно виконати команду меню Файл → Зовнішні дані → Зв'язок з таблицями. Запуститься майстер установки зв'язку, кроки якого аналогічні діям майстра імпорту. У результаті буде встановлений динамічний зв'язок з даними з Excel, а в списку таблиць у вікні бази даних Access з'явиться нова таблиця, позначена спеціальною піктограмою у вигляді стрілочки, що позначає, що дана таблиця є зв'язаною.

Після установки зв'язку дані, що зберігаються в зв'язаній таблиці, можна обробляти як у Excel, так і в базі даних Access.

Якщо надалі файл — джерело даних буде перейменований чи переміщений в іншу папку, то зв'язок буде порушено. Для відновлення зв'язку потрібно буде вказати нове місце розташування вихідного файлу за допомогою команди меню Сервіс → Службові програми → Диспетчер зв'язаних таблиць.

Аналогічним чином виробляється імпорт і зв'язування даних з однієї бази даних MS Access в іншу.


^ 2.5 Експорт даних з Access у Word і Excel

Як би не була зручна і продуктивна обробка даних у базах даних Access, усе-таки його «виразні» засоби часом бідніше, ніж у Excel чи Word (Access складніше й у ньому менше можливостей оформлення). Наприклад, у Excel можна більш наочно (головне — у звичній для користувача формі) представити інформацію в табличному вигляді і набагато простіше створювати і змінювати діаграми.

У меню Сервіс → Зв'язки з Office знаходяться три команди експорту даних з Access у Word і Excel:

  • Аналіз у MS Excel;

  • Публікації в MS Word;

  • Злиття з MS Word.

Щ
об відправити дані з Access у Excel, у вікні бази даних Microsoft Access необхідно вибрати таблицю, запит, форму чи звіт, а потім виконати команду меню Сервіс → Зв'язки з Office → Аналіз у MS Excel (мал. 9). Microsoft Access збереже таблицю, запит, чи форму звіт у вигляді книги Microsoft Excel (.xls) і відкриє цей файл у Microsoft Excel. Файл з ім'ям таблиці, запиту чи іншого об'єкта бази даних зберігається в поточному робочому каталозі (за замовчуванням «C:\Мої документи»).


Рис. 9. Команда Зв'язку з Office у Microsoft Access

^ 2.6 Експорт документів у HTML-формат

Сьогодні для багатьох стало необхідним розміщати дані в мережі Internet.

Щоб швидко підготувати інформацію з офісних програм для публікації в Web, не потрібно знати теги мови HTML — досить просто зберегти її у форматі гіпертекстового документа. Для цієї мети в Word і Excel додана спеціальна команда меню Файл → Зберегти як Web-сторінку.

П
ісля виконання цієї команди відкриється вікно «Збереження документа», у якому можна змінити заголовок документа (кнопка «Змінити»), а також параметри HTML-документа (кнопка «Сервіс» → Параметри Web-документа) (мал.10). Потім натисніть кнопку «Зберегти», і ви одержите готову Web-сторінку.

Рис. 10. Указівка параметрів Web-документа при експорті в HTML

При збереженні документа у форматі HTML неминуче втрачаються деякі елементи форматування, тому, перш ніж виконувати експорт, скористайтеся командою Файл → Попередній перегляд Web-документа для оцінки результату.

Отриманий у результаті Web-документ можна буде розмістити в мережі Internet і переглядати за допомогою програм-браузерів. Результат, звичайно, далекий від досконалості (особливо громіздкий HTML-код), однак простота і швидкість створення такої Web-сторінки в наявності.


3. Експорт даних ^ MACROMEDIA FLASH

Використання режиму Експорт дозволяє готувати Flash файли придатні для використання в інших додатках. Програма передбачає можливість визначити параметри настроювання тільки для одного типу носіїв, щораз коли Ви використовуєте Export Movie чи Export Image.

Flash не зберігає настойку експортних параметрів окремо для кожного файлу.

^ Команда Export Movies експортує закінчений зміст Flash Movie в один з підтриманих типів файлів. Якщо Ви використовуєте Export Movies, щоб експортувати кліп Flash в один з форматів зображення, Експорт створює пронумеровані завантажувальні модулі для кожного кадру в кліпі. Ви можете також використовувати Export Movies, щоб експортувати звук із кліпу в WAV файл (Тільки Windows).

^ Команда Export Image експортує зміст поточного кадру чи обраного зображення в один з форматів зображення, чи в кадр Flash кліпу. Коли Ви експортуєте зображення Flash як векторно-графічний файл (Ілюстратор), Ви зберігаєте його векторну інформацію.

Ви можете редагувати ці файли в інших векторно-орієнтованих програмах, але Ви не можете імпортувати ці зображення в більшість програм обробки текстів і розмітки сторінок. Коли Ви зберігаєте зображення Flash як растровий GIF, JPEG, PICT (Macintosh), чи BMP файл (Windows), зображення втрачає його векторну інформацію і зберігає тільки піксельну інформацію.

Ви можете редагувати зображення Flash, експортовані як крапкові малюнки в редакторах зображення типу Photoshop, але Ви більше не можете редагувати їх у векторно-орієнтованих програмах.

^ Використання Export Movie і Export Image: Якщо Ви експортуєте зображення, виберіть кадр чи зображення в поточному кліпі, що Ви хочете експортувати. Виберіть File → Export Movie чи File →Export Image. Введіть ім'я для вихідного файлу. Виберіть тип файлу зі спливаючого меню форматів. Натисніть Save. Якщо формат, що Ви вибрали, вимагає докладної інформації, з'явиться діалогове вікно Export. Установите експортні параметри для формату, що підходять для Вас і натисніть OK. Натисніть Save.

Висновки

Перенос інформації з одного офісного додатка в інший дозволяє найбільше ефективно працювати з даними. Обмін даними можна організувати, використовуючи буфер обміну, а також операції імпорту й експорту. А для роботи з загальними даними з різних додатків зручно організувати зв'язок із джерелом даних.


Список використаних джерел


  1. Дибкова Л. М. Інформатика та комп’ютерна техніка. — К.: Академвидав, 2002;

  2. Завьялов А., Завьялова И. Экспорт/импорт данных в приложениях Microsoft Office 2000 // КомпьютерПресс 7'2001;

  3. Сафронов Ю.Экспорт объектов приложения // http://safsoft.h1.ru/clause/morphx.html;

  4. http://aqua.sci-nnov.ru/informatika/Metodics/CreateComplexDoc/CreateComplexDoc.htm



Схожі:

Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconІнтегроване використання засобів опрацювання документів обмін даними між офісними додатками. Імпорт та експорт файлів. Практична робота «Виконання завдань з опрацювання даних у кількох програмних середовищах» і-етап
Зберегти створену таблицю у файлі Таблиця doc doc в папці Pr robota. Увага! Обчислень не проводити
Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconMaxim Borisov Certifications Microsoft Certified Trainer Microsoft Certified Professional Microsoft Certified Technology Specialist (Microsoft Office Project Server 2007, Managing Projects;

Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconЗаява про отримання погодження на експорт та імпорт озоноруйнівних речовин та продукції, що їх містить
Порядку видачі погодження для отримання ліцензії на експорт та імпорт озоноруйнівних речовин і продукції, що їх містить
Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconПовідомлення заявника про орієнтовний термін виконання головний спеціаліст відділу міжнародного співробітництва управління в протягом 1 дня (у день надходження документів) 2
Прийом І перевірка повноти пакету документів, фіксація дати надходження документів у журналі обліку заяв суб’єктів зед області на...
Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconПакет Microsoft Office (ms word, ms publisher, ms power Point); Браузер (Internet Explorer, Opera); Опорні конспект
Методична розробка відкритого уроку лабораторної роботи з предмету “ Основи технічного редагування та оформлення тексту ” на тему...
Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconСтатистичний аналіз імпорту, експорту морозива по україні (за даними Держкомстату України)

Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 icon201001201333210. Dokument Microsoft Office Word

Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconПогоджено: Директор Дочірнього підприємства Державної компанії з експорту та імпорту продукції послуг військового та спеціального призначення «Укрспецекспорт» Державного госпрозрахункового зовнішньоторговельного підприємства «Спецтехноекспорт» Гладуш І. В
Директор Дочірнього підприємства Державної компанії з експорту та імпорту продукції послуг військового та спеціального призначення...
Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconКалендарний план виконання курсової роботи з дисципліни «Інформаційні системи І технології в економіці» для студентів спеціальності «Економічна кібернетика», групи ек-31 денна форма навчання на 2012-2013 н р
«Інформаційні системи і технології в економіці» для студентів спеціальності «Економічна кібернетика»
Реферат на тему \" Експортні системи\" План Використання технології ole, експорту/імпорту файлів > Експорт/імпорт даних у додатках Microsoft Office 2000 iconСистеми управління базами даних
Проектування бази даних. Створення структури. Типи даних, які використовуються в бд. Введення та редагування даних
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©sm.znaimo.com.ua 2000-2015
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи

Разработка сайта — Веб студия Адаманов